Jump to content

Brand new, bricked after a software update?


TneObnoxiuosSorcerer

Recommended Posts

Need some help please

I got the Shelly Blu button 1 a few days ago, setup is confusing in the App.

Not only that, I can not get it to work anymore, it won't let me reset in the App, I see the spinning wheel, nor

can I pair it anymore.

Holding the button for 30 seconds will reset the button, it reset once, after that it is impossible to reset.

Pretty sure there's a bug in the Button Firmware, must be otherwise it should be able to reset more than once.

What now, is there another way to reset or is this device bricked.

It's such a shame, was looking forward to open my front doors, yes doors (Appartement), it's unusable now.

Shelly...look into it

On an iPhone 14 iOS

Cheers Perry

 

 

Note: While you're at it, you might rethink the new App, it's confusing, and the paid service should be banned.

 

 

 

image.thumb.png.c7f9d4153d8cd5bbd7602682120728a8.png

 

 

 

Link to comment
Share on other sites

  • Moderators

Try this:

1. Remove the battery from the BLU button.
2. Remove the Bluetooth BLU button from the saved pairing setting on your phone, if available.
3. Restart the mobile phone
4. Launch the Shelly Blue Debug app:https://apps.apple.com/us/app/shelly-ble-debug/id6449539118
5. Press the button on the BLU button and insert the battery while holding the button.
6. Now press the button on the BLU button, the BLE Debug app should confirm this in the log display.
7. In the BLE Debug app, click OTA. Now the OTA counter should show 0-100% and the update should be successful.

Link to comment
Share on other sites

1 hour ago, Olsche said:

Try this:

1. Remove the battery from the BLU button.
2. Remove the Bluetooth BLU button from the saved pairing setting on your phone, if available.
3. Restart the mobile phone
4. Launch the Shelly Blue Debug app:https://apps.apple.com/us/app/shelly-ble-debug/id6449539118
5. Press the button on the BLU button and insert the battery while holding the button.
6. Now press the button on the BLU button, the BLE Debug app should confirm this in the log display.
7. In the BLE Debug app, click OTA. Now the OTA counter should show 0-100% and the update should be successful.

Thank you, I will try this later own when I am back from Dinner party.

Link to comment
Share on other sites

I think I got it to work, button pushes are registered in the app, now setting a scene did

not work yet, must be me though, but in my opinion it can be done much easier then the

convoluted way it is done now, just add 4 buttons in the setting for the BLU button

Anyhow, thanks for the help

Down below is what I got for quite a while, it seems to be buggy, just sheer luck that

I got it to work.

-------------------------------------------------------------------------------------------------------------------------

I see the progress from 0-100% without pressing the OTA button.

 

I get 2 situations

1: I get the bluetooth pairing request on my iPhone, asks for the code, see below, anything else does

not work, including resetting the button.(Picture 1)

2: I have to hold the (pairing) button for 10 seconds, whatever I do it never connects, also

reset not possible and all buttons greyed out, see below.(Picture 2)

Picture 

IMG_2610.thumb.PNG.d1d41801c636a68cc37e7fc2848c0805.PNG  

Picture 2

IMG_2611.thumb.PNG.5f1aab6582558c926a28f3dfda81b111.PNG

 

 

 

 

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...