Jump to content
New translation feature for the Shelly Forum ×

Shelly Pro 4PM problem with LAN connection ETH


xnd

Recommended Posts

Hello Dear Shelly community,

I have Shelly Pro 4PM (version 1)

with some older firmware (I'm not sure what version it was) everything was working ok. LAN connection was stable, without issues (also when ECO mode enabled or disabled).

Today I upgraded firmware to 1.2.2 stable and cable ETH connection stopped working.

Then I tried to upgrade to latest beta (1.3.0-beta1-gd5dbd46) and this issue was still here.

I have tried also restart device, enable / disable ECO mode. Disable Ethernet, restart. Enable ethernet, restart. And this issue was still here.

Then I switched back to stable firmware 1.2.2. And this issue was still here.

Then I did a factory reset. Issue was still here. Ethernet connection is broken.

 

Please see my video:

  • you can see that ETH status is most of the time disconnected but sometimes is shows correct IP address for 1 sec and then immediately shows disconnected.
  • you can see LEDs in RJ45 are turned off and blinking in regular interval.

 

What I tried:

  1. switch to latest beta fw (1.3.0-beta1-gd5dbd46)
  2. switch to latest stable fw (1.2.2)
  3. factory reset
  4. ECO mode enabled
  5. ECO mode disabled
  6. Enable/disable Ethernet (and reboot)
  7. power off device, power on
  8. different LAN cables, connect to different switch and router.
  9. Ethernet configuration DHCP
  10. Ethernet configuration static IP
  11. I did "ping" command from PC to Shelly static Ethernet IP address every 1 sec. 100 attempts, 100% packet loss.
  12. I tried to set port on the switch where Shelly is conected to 100 Mbit (disable auto-negotiation)

 

Nothing helped.

 

Edited by xnd
add list of things what I tried to resolve this issus
Link to comment
Share on other sites

Posted (edited)

 - also we can observe the same in shelly cloud web interface (https://control.shelly.cloud/#/home/devices/-1)  - Ethernet connection is most of the time disabled and it appears for 1 second as connected.

.

 

Edited by xnd
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...