Jump to content
Shelly IoT Innovation Challenge started! ×

Shelly Plus 1: need for Cloud when sensing input?


JPol

Recommended Posts

Hi Community

I am using a Shelly Plus 1 for monitoring the on/off state of an external contactor contact (input in "detached mode").

I noticed that if I turn off the Cloud connection, the input doesn't react anymore.

Did I configure anything wrong?

Link to comment
Share on other sites

I have enabled the use of the local network control as you indicated.

I monitor it via Home Assistant on my local network. The paring process with Home Assistant went flawlessly.

Even via the Shelly app it didn't work without the Cloud enabled.

I'll test again this evening.

Link to comment
Share on other sites

Just tested it again. If I disable the cloud, the input (red to green indicator) doesn't work.

I've saved my Wifi fixed IP again but no avail. I've used the app and the direct connection to the Plus 1 via the

web browser. Always the same: no cloud, no indication of the input.

Any suggestions?

Link to comment
Share on other sites

  • Administrators
2 hours ago, JPol said:

via the web browser. Always the same: no cloud, no indication of the input.

By web browser do you mean control.shelly.cloud or WEB-UI?

In the app there are delays of up to 15 seconds until the status indicator changes if you have deactivated the cloud and are using the app in local mode.

The status change can be seen in the WEB UI at any time despite the cloud being deactivated.

 

Screenshot2024-01-28at22-13-40ShellyPlus1.thumb.png.cf648eb825922ea76910b5e2357c0d7d.png

Button Type is "Switch?

 

please share: http://IP_your_Plus1/rpc/shelly.getconfig

 

Link to comment
Share on other sites

  • Members

I have many Plus devices including Shelly Plus 1 with cloud connection disabled and they report the status correctly in Home Assistant. 

Note that according to HA guidelines there are different sensors/events depends if the input is a switch or a button:

https://www.home-assistant.io/integrations/shelly/#binary-input-sensors-generation-2-and-3

https://www.home-assistant.io/integrations/shelly/#event-entities-generation-2-and-3

I think the best way would be to create an issue for Home Assistant https://github.com/home-assistant/core/issues/new?assignees=&labels=&projects=&template=bug_report.yml with logs and diagnostics to understand the root cause.

 

Link to comment
Share on other sites

Sorry for the late reply.

Indeed, that was the problem: no patience from my side. When not connected to the cloud, it takes 15 sec to get an input status change.

So, I'll keep all of my Shelly Plus 1 on the cloud. 

Problem solved.

Thank you Olsche and Shay !!!!!

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...