Jump to content
New translation feature for the Shelly Forum ×

RPC over UDP broken in latest firmware


Recommended Posts

This morning I bought two packs of 5 Shelly Plus Plug S (Black) v2 type F devices and updated the firmware to stable version 1.2.3 (for all 10 of them)

An hour ago I just noticed that new stable version 1.3.0 was released, so I set up 5 plugs and updated all 10 plugs on version 20240425-141453/1.3.0-ga3fdd (if needed my web build ID is: 240425094011-02c46958-HEAD)

Now I tried to finish off those 5 remaining plugs and immediately noticed I am denied to set RPC over UDP (this worked alright on previous firmware version) and whatever value I plug in I receive this error message: "Enter a value corresponding to the required format". As example in the field suggests the format should be 192.168.0.1:1111

Moreover, that first set of 5 plugs that I set up, when I try to change the valid value to some new value I get the same error again!

In summary, RPC over UDP is broken in the latest firmware. 

Did the format change? If yes, what is the new format? If not, what are my options? Where can I download previous firmware to roll back? 

Any guidance much appreciated.

ff.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...