Jump to content
Shelly IoT Innovation Challenge started! ×

Shelly App Error no Bluetooth permission


max2

Recommended Posts

Hy,

the Shelly app already worked well on my Pixel 6.
 
But for a few days now I've been getting the following error when starting:
"In order to find Bluettoth devices, the app requeres permisson to use Bluetooth"

Bluetooth is ON and I checked the permissions in the settings, it looks okay too.
 
What else can I check and change to fix the problem?
 
That's why I can't set up any new Shelly devices at the moment
 
Thanks
Link to comment
Share on other sites

I have the same issue on a OnePlus One nord 3, its not possible to allow the app to use bluetooth anymore. 

 

There might possible be an issue with the Android manifest in the latest deployment?

Link to comment
Share on other sites

I finally got it to work, or found a way to get it out of a bad state.

I had tried to update the phone to the latest, had 2 individual updates on the phone i applied with restarts etc. - but it was still broken.

 

What i just did was:

Delete the cache. 

Delete the appdata.

uninstall the app

reinstall the app.

- still had bluetooth errors.

Deaktivated the bluetooth on the phone. 

made a Shutdown on the phone, not a restart.

turned the phone on. 

entered the app, and the app asked to turn on the bluetooth, which I accepted.

It now works again.

what ever part of it that made it work i dunno excatly, but this was the steps i did.

@max2 dunno if that would help you aswell.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...