Jump to content
Gen2 Devices: FW Update Required / Gen2 Geräte: FW-Update erforderlich ×

Shelly 1PM Gen 1 (not Plus) devices on Hot Water Cylinders keep going offline


Recommended Posts

Hi,

I have two Shelly 1PM running two (separate) Hot Water Heaters, each wired to a Schneider Contactor switch (all wiring done by a registered electrician).
They work well, when not disconnected form Wifi and the Cloud, which is my issue.

When they disconnect (which is often and at no fixed time) I cannot access them via the Cloud nor directly via a static IP Address; nor ping them i.e. they are "offline". Oddly, they appear to BOTH go offline at exactly (or around?) the same time, although they are on two separate and independent Hot Water Heater circuits.

They come back online by themselves after some time, (normally a few hours, max one day or overnight) and not always but sometimes also if I reboot the router (remotely). RSSI values are -44dBm and -61dBm, not stellar but good enough. Power on default mode is restore last mode.

I appreciate this topic is oft-quoted on other forums, with amongst other solutions, these ones, all of which I have tried:

I have not tried to:

  • Reset the devices (they are 9000km away atm, but will try when I get there); nor have I tried to
  • Install Tasmota or ESPHome or any other firmware as I do not prefer to do this ATM (and Home Assistant, if I ever install it, works fine with the native FW); nor have I tried to
  • Install an RC Snubber, as it is not wired to an inductive system such as a Fan, Washing Machine etc. so I do not believe this would help but I am happy to hear otherwise; nor have I tried to
  • Replace any capacitors (16V and 100uF), as this was a 'faulty capacitor issue' associated mainly (only?) with the Shelly 2.5 PM I believe; nor have I tried to
  • Change the port in CoIoT to 5683, as I do not (yet) run HomeAssistant and it only applies to that platform (I would be willing to try it if it fixed it!).
  • Change the Wifi to a Fixed Channel

I tried enabling the debug and attach the two logs for each device (total 4); I do not see any obvious reasons for disconnects.
Oddly the debug moide switched itself off after they came back online (yet again), is this normal?

I am leaning towards a more modern Shelly Plus 1PM or Shelly 1PM Gen3 for CPU and RAM, but will it help?

Does anyone see anything in the logs?
Any thoughts or suggestions please? I am at my wit's end.

TIA

k.

 

241_Prev.txt 241_Curr.txt 242_Prev.txt 242_Curr.txt

Edited by SmurfnSurf
Typos; additional methods
Link to comment
Share on other sites

If they are wired to a Schneider Contactor then they have an inductive load and an RC Snubber must be used. The contactor gives a high voltage spike when switched off and that may very likely disturb the Shelly.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...